[Haskell-cafe] Cabal dependency hell

Bulat Ziganshin bulat.ziganshin at gmail.com
Mon Mar 8 09:02:32 EST 2010

Hello Maciej,

Monday, March 8, 2010, 4:33:08 PM, you wrote:

> PS. I understand that content may be flame-gen. I am sorry in advance if
> such circumstances happen. However I believe that possible improvements
> in process are worth the risk.

i was the author of this idea and i thought that

1) package author should allow to use only versions of dependence that
he know will work

2) if new version of dependence arrives, package author should upload
minor update of his package that allows to use it

Best regards,
 Bulat                            mailto:Bulat.Ziganshin at gmail.com

More information about the Haskell-Cafe mailing list