[Haskell-cafe] Hackage vs. legacy support in Cabal files

John D. Ramsdell ramsdell0 at gmail.com
Fri Mar 5 09:45:05 EST 2010

I'd like to support Hackage and GHC 6.8 with one source distribution.
The enclosed Cabal file would do the trick if Hackage would simply
evaluate the Cabal file using the default flag values.  Instead, it
chokes on a hack required to support GHC 6.8.  The directory
containing the autogen files has to be on the source path.

  if flag(old)
    Hs-Source-Dirs:	src dist/build/autogen
    Hs-Source-Dirs:	src

Is there a way to force Hackage to respect flag values?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cpsa.cabal
Type: application/octet-stream
Size: 6937 bytes
Desc: not available
Url : http://www.haskell.org/pipermail/haskell-cafe/attachments/20100305/eb3e59db/cpsa.obj

More information about the Haskell-Cafe mailing list