[Haskell-cafe] Re: [Haskell] ANNOUNCE: Sifflet visual programming language, release 0.1.7

gdweber at iue.edu gdweber at iue.edu
Sat Jun 12 15:43:25 EDT 2010

Thanks to all for reminding me of the Package Versioning Policy (PVP); 
I have refreshed my memory of it here:


The message I'm picking up from this thread is that

In *theory* if my package works with some other package P,
version A.B.C, and 
   a.  I'm importing the whole module P unqualified, then my cabal file
       should say my package depends on P >= something && < A.B.(C+1).
   b.  If I'm importing P qualified or only certain names from P,
       then I can be more relaxed in my cabal file can say my package 
       depends on P >= something && < A.(B+1).

In reality, eternal vigilance is required, since some packages
may be released with new version numbers not conforming to the PVP.

But what about *lower* bounds for package dependencies?
I think what I tend to do is something like this.
I'm developing my package and using P with installed
version P == A.B.C.  So I write in my cabal file that
it depends on P >= A.B.C.  

Then some time later, I get a newer version of P
with version A'.B'.C' > A.B.C,
and I'm not aware of any significant changes, 
so I go on declaring in my cabal file
that my package depends on P >= A.B.C,
even though I *might* be using new features of P
that wouldn't work with P == A.B.C.

Does anyone suggest a better way of dealing with the
lower bound package versioning?

> On Fri, 11 Jun 2010, Ben Millwood wrote:
> >On Fri, Jun 11, 2010 at 2:52 PM, Henning Thielemann
> ><lemming at henning-thielemann.de> wrote:
> >>
> >>I'm uncertain whether fgl conforms to the package versioning policy, but
> >>if it does, then changes in its Cabal file should not bother sifflet.
> >>Thus upper bound fgl < 5.4.3 should be restrictive enough.
> >>
> >
> >The PVP says that one of the first two numbers are required to change
> >if an API change is likely to break code using it, so < 5.5 would
> >probably suffice.
> A bump to fgl-5.4.3 might include API *extensions* that may break
> sifflet, if it imports entire FGL modules in an unqualified way.
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

   ___   ___  __     _      
  / _ \ / _ \| |    | |     Gregory D. Weber, Associate Professor
 / /_\// / | | | /\ | |     Indiana University East
/ /_\\/ /__| | |/  \| |     http://mypage.iu.edu/~gdweber/
\____/\_____/\___/\__/      Tel. (765) 973-8420; FAX (765) 973-8550

More information about the Haskell-Cafe mailing list