[Haskell-cafe] Re: [Haskell] ANNOUNCE: Sifflet visual programming language, release 0.1.7

Henning Thielemann lemming at henning-thielemann.de
Fri Jun 11 10:51:09 EDT 2010

On Fri, 11 Jun 2010, Ben Millwood wrote:

> On Fri, Jun 11, 2010 at 2:52 PM, Henning Thielemann
> <lemming at henning-thielemann.de> wrote:
>> I'm uncertain whether fgl conforms to the package versioning policy, but
>> if it does, then changes in its Cabal file should not bother sifflet.
>> Thus upper bound fgl < 5.4.3 should be restrictive enough.
> The PVP says that one of the first two numbers are required to change
> if an API change is likely to break code using it, so < 5.5 would
> probably suffice.

A bump to fgl-5.4.3 might include API *extensions* that may break sifflet, 
if it imports entire FGL modules in an unqualified way.

More information about the Haskell-Cafe mailing list