[Haskell-cafe] hsql won't install due to system.time

Brian Denheyer briand at aracnet.com
Thu Jan 21 09:51:13 EST 2010

On Thu, 21 Jan 2010 11:36:42 +0100
Marc Weber <marco-oweber at gmx.de> wrote:

> Hi Brian
> hsql is compatibel with most recent ghc yet.

Well I am using 6.10.4, so should I use a patched version, or simply
apply the fixes which Malcolm provided ?

> You can get patches for the .cabal files here:
> http://github.com/MarcWeber/haskell-nix-overlay/tree/master/patches/
> However the Exception handling has to be rewritten as well.
> I wanted to fix this issues for weeks - No time.

Are you waiting to get this  done before releasing a new version to
Hackage ?

> Let me know if you start working on this.

You _really_ don't want me working on anything, trust me.  Hopefully
some fine Haskell hacker who would also like to use hsql will volunteer.


More information about the Haskell-Cafe mailing list