GUI (was: Re: [Haskell-cafe] DLL on Windows)

Jeremy O'Donoghue jeremy.odonoghue at
Wed Feb 17 06:17:10 EST 2010

You're probably correct about the dependencies. I have never tried to
compile wxHaskell against GHC 6.12.1

I'm waiting for Haskell Platform to be released to make the required
changes since (working primarily on Windows) I just don't have time to
create a complete GHC 6.12 installation with most of the HP libraries
(some of which are a pain to get working on Windows).

wxHaskell will support GHC 6.12.x within a couple of days of release of
a suitable Haskell Platform.


On Tue, 16 Feb 2010 17:55 -0800, "Thomas DuBuisson"
<thomas.dubuisson at> wrote:
> On Tue, Feb 16, 2010 at 3:48 PM, Henk-Jan van Tuyl <hjgtuyl at>
> wrote:
> > On Tue, 16 Feb 2010 18:57:20 +0100, Neil Mitchell <ndmitchell at>
> > wrote:
> >
> >> I used to recommend Gtk2hs over wxHaskell for GUI development as there
> >> was always a version that worked on Windows with the latest GHC
> >> release. I think I might have to switch back to recommending C# for
> >> GUI development...
> >
> > The latest revision of wxHaskell can be compiled relatively easy, so that
> > wxHaskell can be used immediately for the latest version of GHC.
> Exciting allegation, but it doesn't quite check out with GHC 6.12.1 +
> cabal and cabal-install 0.8 (see below).  I would expect this
> issue to be easily resolved by specifying "containers <= 0.3.*" in the
> "wxdirect" package, but cabal is misbehaving (for me) and stating
> wxdirect needs reinstalled with a supposedly newer version of
> containers,
> Thomas
> [tommd at Mavlo ~]$ cabal install wx
> Resolving dependencies...
> Downloading containers-
> Configuring containers-
> Preprocessing library containers-
> Building containers-
> Data/IntMap.hs:182:7:
>     Could not find module `Data.Data':
>       It is a member of the hidden package `base'.
>       Perhaps you need to add `base' to the build-depends in your .cabal
>       file.
>       Use -v to see a list of the files searched for.
> cabal: Error: some packages failed to install:
> containers- failed during the building phase. The exception was:
> ExitFailure 1
> wx- depends on containers- which failed to install.
> wxcore- depends on containers- which failed to install.
> wxdirect- depends on containers- which failed to install.
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at
  Jeremy O'Donoghue
  jeremy.odonoghue at

More information about the Haskell-Cafe mailing list