[Haskell-cafe] Cabal, xmonad-contrib, X11-xft, pkg-config ... questioning my sanity

Jacek Generowicz jacek.generowicz at cern.ch
Mon Dec 6 19:25:09 CET 2010

On 2010 Dec 6, at 16:25, Duncan Coutts wrote:

> Perhaps something like this would be better:
> cabal: The program 'pkg-config' is required but it could not be found
> on the system (version 0.9.0 or later of pkg-config is required).

That looks pretty good. I'm having trouble finding any holes in it.

There is also the issue (if my understanding is correct) that cabal  
install only needs pkg-config for some packages. So it is possible  
that someone has happily been using cabal install for some time, and  
then suddenly it doesn't work. And then they are left wondering what  
broke: "But I'm sure it worked last week, and I haven't changed  
anything" etc. At which point it could be helpful to be told that it's  
a circumstantial rather than a fundamental problem.

More information about the Haskell-Cafe mailing list