[Haskell-cafe] Cabal, xmonad-contrib, X11-xft, pkg-config ... questioning my sanity

Duncan Coutts duncan.coutts at googlemail.com
Mon Dec 6 16:25:19 CET 2010

On 6 December 2010 14:48, Jacek Generowicz <jacek.generowicz at cern.ch> wrote:

> Another thing that would probably have made it easier to understand: the
> message is strictly correct, but is *too* specific: it talks about
> pkg-config version >=0.9.0 not being found, while the problem was that *no
> version at all* was present.
> I would understand if making the error message change according to such
> subtle distinctions would be more effort that it is worth.

Yes. The version is there so that when you do go and install it, you
will know what version to look for, so you don't end up in the
situation where you've gone to all the effort of installing
pkg-config, only to find it now complains that it found it, but it was
too old.

Perhaps something like this would be better:

cabal: The program 'pkg-config' is required but it could not be found
on the system (version 0.9.0 or later of pkg-config is required).


More information about the Haskell-Cafe mailing list