[Haskell-cafe] Re: [darcs-users] ANNOUNCE: darcs 2.5 beta 4

Eric Kow kowey at darcs.net
Wed Aug 25 11:48:11 EDT 2010

On Wed, Aug 25, 2010 at 13:01:59 +0200, Benjamin Franksen wrote:
> I found that the build uses ghc-6.8.3 which, I think, is no longer supported 
> for building darcs, IIRC.
> Sorry for the noise.

Not noise because it resulted in http://bugs.darcs.net/patch365
which attempts to enforce this dependency by raising the base
package floor from >= 3 to >=4, which I imagine is not a mistake.

I'm keeping the haskell-cafe CC because I was puzzled for a while about
how to make Darcs explicitly depend on GHC 6.10 and wanted to share the
steps I eventually took:

1. visit GHC download page (we're looking for older versions)

2. scroll down to earliest GHC 6.10

3. click on release notes

4. search for 'base package'

Maybe somebody will shout if this turns out to be the wrong way to
approach things, or if it's fundamentally unwise.

Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
For a faster response, try +44 (0)1273 64 2905 or
xmpp:kowey at jabber.fr (Jabber or Google Talk only)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
Url : http://www.haskell.org/pipermail/haskell-cafe/attachments/20100825/67ce3bdb/attachment.bin

More information about the Haskell-Cafe mailing list