[Haskell-cafe] Confusions about the Haskell Platform (for Mac)

Daniel Fischer daniel.is.fischer at web.de
Wed Apr 7 18:25:45 EDT 2010

Am Donnerstag 08 April 2010 00:09:34 schrieb Ivan Lazar Miljenovic:
> Daniel Fischer <daniel.is.fischer at web.de> writes:
> > I currently have 6.10.1, 6.10.3 and 6.12.1 installed (openSuSe 11.1),
> > no problem.
> > On my previous computer (SuSE 8.2), I had every release from 6.2.2 to
> > 6.8.2, no problem either.
> Using system packages?

Of course not, I'm a source freak (except the 6.10.1, one has to get 
started somehow).

> > Ah, but one shouldn't use a package manager for Haskell packages.
> > Cabal is far superior to all of them 8-)
> Except for the fact that you can't uninstall,

Well, I can uninstall manually if I really want to, but disk space isn't 
that scarce yet.

> check for non-Haskell-library dependencies,

True, a distro package manager could do that.
However, so far I've found the ease of managing Haskell packages via cabal-
install worth much more than taking care of the occasional non-Haskell 

> etc. ...

Such as?

More information about the Haskell-Cafe mailing list