[Haskell-cafe] Building com-1.2.3

Andrew Coppin andrewcoppin at btinternet.com
Mon Sep 21 14:59:33 EDT 2009

Don Stewart wrote:
> andrewcoppin:
>> Don Stewart wrote:
>>> Have you tried installing the C libraries it requests?
>> kernel32.dll, user32.dll, etc. are all standard DLL files present in  
>> C:\WINDOWS\system32.
>> I was hoping that saying --extra-lib-dirs=C:\WINDOWS\system32 like the  
>> error message suggests would magically fix the problem... but no. I  
>> guess that would be too easy.
>> It also doesn't explain why Cabal isn't finding include/WideStringSrc.h,  
>> even though that's the correct relative path to the file. I checked six  
>> times; it's definitely there.
>> I also had a look around to see if there's any readme files in the Cabal  
>> package or any helpful hints on the package website. I found some  
>> example code, but nothing about how to get it to compile. :-(  
>> [Presumably because for the author it worked without doing anything  
>> special.]
> Compile with -v3 or so, to get full debugging output on the PATH and
> explicit paths being used.

I see several dozen lines like this:

D:\ghc\ghc-6.10.3\gcc.exe returned ExitFailure 1 with error message:
cc1.exe: error: unrecognized command line option "-fenable-stdcall-fixup"
cc1.exe: error: unrecognized command line option "-fdisable-stdcall-fixup"

So perhaps it's not that it can't find stuff, it's that it doesn't like 
the strange options inserted from the Cabal file? It contains the 
following gem:

-- I can't seem to feed this into the 'ld' invocation that creates the
-- relocatable object file.
 Ld-options: --enable-stdcall-fixup --disable-stdcall-fixup

Presumably the author did this for some sort of specific reason. I have 
no clue what though.

> Have you contacted the author?

No, I hadn't actually thought of that...

More information about the Haskell-Cafe mailing list