[Haskell-cafe] Building com-1.2.3

Don Stewart dons at galois.com
Mon Sep 21 14:37:20 EDT 2009

> Don Stewart wrote:
>> andrewcoppin:
>>> Andrew Coppin wrote:
>>>> C:\com-1.2.3>runhaskell Setup configure
>>>> Configuring com-1.2.3...
>>>> Setup: Missing dependencies on foreign libraries:
>>>> * Missing header file: include/WideStringSrc.h
>>>> * Missing C libraries: kernel32, user32, ole32, oleaut32, advapi32
>>>> Any hints?
>> Have you tried installing the C libraries it requests?
> kernel32.dll, user32.dll, etc. are all standard DLL files present in  
> C:\WINDOWS\system32.
> I was hoping that saying --extra-lib-dirs=C:\WINDOWS\system32 like the  
> error message suggests would magically fix the problem... but no. I  
> guess that would be too easy.
> It also doesn't explain why Cabal isn't finding include/WideStringSrc.h,  
> even though that's the correct relative path to the file. I checked six  
> times; it's definitely there.
> I also had a look around to see if there's any readme files in the Cabal  
> package or any helpful hints on the package website. I found some  
> example code, but nothing about how to get it to compile. :-(  
> [Presumably because for the author it worked without doing anything  
> special.]

Compile with -v3 or so, to get full debugging output on the PATH and
explicit paths being used.

Have you contacted the author?

-- Don

More information about the Haskell-Cafe mailing list