[Haskell-cafe] Cabal says "no installed version of base"

John Velman velman at cox.net
Wed Oct 21 19:05:32 EDT 2009

I'm on OS X Leopard 10.5.8, using ghc 6.10.4 from Haskell Platform.

I'm trying to get a static .a library, callable from C, that I can use in
an OS X Cocoa program.  I've tried a very simple case (the one in Haskell
Wiki Tutorials,"calling haskell from C") I've managed to make a Mac Cocoa
application by adding the ghc generated .o program, plus adding one by one
the needed Haskell libraries for "symbol not found" to my Xcode project.
There should be a better way.

I've tried just about everything I could find on creating Haskell
libraries, with no joy.  My latest try is to use Cabal, following advice
found both in "How to write a Haskell program" and the Cabal users guide.

My output from cabal -v configure tells me, among others:
Reading installed packages...
/usr/bin/ghc-pkg dump --global
/usr/bin/ghc-pkg dump --user
Reading available packages...
Resolving dependencies...
There is no installed version of base

But when I do ghc-pkg dump --global it appears base is listed.  

Apparently, "no installed version of base" short circuits the whole

Any suggestions, pointers to reading, whatever will be appreciated. 

More information about the Haskell-Cafe mailing list