[Haskell-cafe] Re: How does cabal determine version ranges in the dependencies?

Maurí­cio CA mauricio.antunes at gmail.com
Mon Nov 23 06:50:07 EST 2009

 > I recently started porting cabal-install to Freebsd. When
 > I looked at its dependencies on hackage, I noticed HTTP
 > (>=4000.0.2 && <4001). However the latest HTTP version on
 > hackage is 4000.0.8. That struck me as kinda odd. How can cabal
 > tell that it won't be compatible with HTTP version 4001?

If it doesn't break dependencies, it won't be called http 4001,
it will be called 4000.0.9 :)




More information about the Haskell-Cafe mailing list