[Haskell-cafe] How does cabal determine version ranges in the dependencies?

David Fries djf at gmx.ch
Mon Nov 23 06:36:55 EST 2009

Hi everyone

I recently started porting cabal-install to Freebsd. When I looked at its dependencies on hackage, I noticed HTTP (>=4000.0.2 && <4001). However the latest HTTP version on hackage is 4000.0.8. That struck me as kinda odd. How can cabal tell that it won't be compatible with HTTP version 4001?

Preisknaller: GMX DSL Flatrate für nur 16,99 Euro/mtl.!

More information about the Haskell-Cafe mailing list