[Haskell-cafe] Problems with Language.Haskell.Interpreter and errors

Daniel Gorín dgorin at dc.uba.ar
Wed Nov 11 08:24:06 EST 2009

On Nov 11, 2009, at 5:39 AM, Martin Hofmann wrote:

> I still have problems and your code won't typecheck on my machine
> printing the following error:
> [...]
> I assume we are using different versions of some packages. Could you
> please send me the output of your 'ghc-pkg list'.
> Thanks,
> Martin


Cabal-, GLUT-, HTTP-4000.0.6, HUnit-,
     OpenGL-, QuickCheck-, array-, base-,
     base-, bytestring-, cgi-3001.1.7.1,
     containers-, directory-, (dph-base-0.3),
     (dph-par-0.3), (dph-prim-interface-0.3), (dph-prim-par-0.3),
     (dph-prim-seq-0.3), (dph-seq-0.3), editline-,
     extensible-exceptions-, fgl-, filepath-,
     (ghc-6.10.4), ghc-prim-, haddock-2.4.2, haskell-src-,
     haskell98-, hpc-, html-, integer-,
     mtl-, network-, network-, old-locale-,
     old-time-, packedstring-, parallel-,
     parsec-, pretty-, process-, random-,
     regex-base-, regex-compat-, regex-posix-,
     rts-1.0, stm-, syb-, template-haskell-,
     time-, time-1.1.4, unix-, xhtml-3000.2.0.1,

   MonadCatchIO-mtl-, ghc-mtl-, ghc-paths-,  
hint-, utf8-string-0.3.5.

Hope that helps


More information about the Haskell-Cafe mailing list