[Haskell-cafe] Re: Ease of Haskell development on OS X?

Colin Adams colinpauladams at googlemail.com
Sun Mar 22 06:32:58 EDT 2009

I tried issuing the sudo port install command on the wiki page.

After some time running it failed with:

To fully complete your installation and make python 2.5 the default, please run

        sudo port install python_select
        sudo python_select python25

--->  Cleaning python25
--->  Fetching py25-hashlib
--->  Attempting to fetch Python-2.5.2.tar.bz2 from
--->  Verifying checksum(s) for py25-hashlib
--->  Extracting py25-hashlib
--->  Configuring py25-hashlib
--->  Building py25-hashlib with target build
Error: Target org.macports.build returned: shell command " cd
&& /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_ext
building '_hashlib' extension
creating build
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include
-c _hashopenssl.c -o build/temp.macosx-10.3-i386-2.5/_hashopenssl.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: gtk-doc
gnome-doc-utils iso-codes py25-hashlib libxslt py25-gobject
py25-libxml2 py25-numeric rarian getopt gtk2 cairo jasper pango
hicolor-icon-theme libgnomeui gnome-icon-theme icon-naming-utils
p5-xml-simple p5-xml-namespacesupport p5-xml-sax gnome-keyring
autoconf help2man p5-locale-gettext m4 gconf libgcrypt libgpg-error
libtasn1 libbonoboui gnome-vfs libglade2 libgnome esound
Error: Status 1 encountered during processing.

Which is singularly uninformative to me. It looks like I am not going
to be able to do any haskell programming next week when I am away with
only a macbook.

2009/3/22 Hans Aberg <haberg at math.su.se>:
> On 22 Mar 2009, at 10:28, Colin Adams wrote:
>> OK, I got it installed, but build warned me of duplicate dylibs, and
>> running my program gave a bus error.
>> So I port uninstalled gtk2, so now it compiled without warnings, but
>> the program won't run because I had been forced to uninstall pangoft
>> to uninstall gtk2.
>> So now I need to uninstall the gtk framework - how do I do that?
>> Then i can re-install the macports version and have a working system
>> again.
> You might move it out of the way:
>  sudo mv /opt /opt1
> and then move it back. To get rid of ports altogether,
>  sudo rm -rf /opt
> (But be careful so you type right when removing as root, as errors can screw
> up the whole installation.)
> I looked up my records - I compiled gtk2hs, and as was remarked, the one in
> MacPorts (but not gtk2 alone) insists on installing its own GHC. When taking
> down the sources (external to MacPorts) of gtk2hs, the .tgz ones worked, but
> the sources from the archive caused some problems with autoconf - despite
> intense discussions also on the gtk2hs list, this problem was left
> unresolved.
> The libraries might cause problems when compiling, because even if a libpath
> is included in the compile, if there are system ones available, then may be
> used - a GCC quirk. So in such cases, one might have to edit the libpath so
> that the system libraries are not at all there, moving selected one out of
> the way, using libtools or something. This is very technical, though.
>  Hans Aberg

More information about the Haskell-Cafe mailing list