[Haskell-cafe] Cabal fun [Half-integer]

Ross Mellgren rmm-haskell at z.odi.ac
Mon Jun 29 16:04:57 EDT 2009

I presume that many of the developers do not have windows machines  
(presumably because windows sucks). Maybe you could help them by  
trying to track down where the error in the code is, and even better  
yet submitting a patch?

This is all free by the virtue of people giving what time they can,  
and if you don't happen to have a windows box to test on, it can be  
very hard to provide compatibility for it. Same in the reverse  


On Jun 29, 2009, at 3:55 PM, Andrew Coppin wrote:

> Jason Dagit wrote:
>> On Mon, Jun 29, 2009 at 11:57 AM, Andrew Coppin <andrewcoppin at btinternet.com 
>>  <mailto:andrewcoppin at btinternet.com>> wrote:
>>    Rather less fortunately, it still doesn't actually fix my problem:
>>    E:\Haskell\AOC-HalfInteger>cabal configure
>>    Resolving dependencies...
>>    Configuring AOC-HalfInteger-1.0...
>>    E:\Haskell\AOC-HalfInteger>cabal sdist
>>    Building source dist for AOC-HalfInteger-1.0...
>>    Preprocessing library AOC-HalfInteger-1.0...
>>    Source tarball created: dist\AOC-HalfInteger-1.0.tar.gz
>>    cabal:
>>    dist\src\sdist.1288\AOC-HalfInteger-1.0\Data\HalfInteger.hs:
>>    removeFile: permission denied (Permission denied)
>>    I have no idea what the hell it's upset about now... I've now been
>>    trying to create this damned tarball since 5PM yesterday, and I
>>    still haven't managed it. At this point I'm losing the will to
>>    continue with this crazy project. Clearly this is way too much
>>    effort to expend just to upload 50 lines of code.
>> I can't say for certain, but just reading the output it looks like  
>> it created a tarball in a temporary folder (that worked) and then  
>> when it tried to clean it up it failed.  Sounds like a bug report  
>> is in order.
> So, yet again, it appears I'm the first poor soul to try using this  
> on Windows.
> The very first time I tried to use Gtk2hs, the installer for Windows  
> was trivially broken. In fairness, Duncan fixed this within an hour  
> or two of me pointing out the problem. But the fact remains: It had  
> been out for a week, and I was the *only* person to have tried to  
> use it on Windows. (Or possibly the only person to actually  
> complain, rather than just give up.) Don kept telling me about some  
> cool Core syntax hilighter he wrote, so I went to all the trouble of  
> downloading it, downloading and building all of its dependencies,  
> only to discover "oh, by the way, it only works on Linux". A while  
> back Cabal had a bug where (on Windows only) it couldn't find ld or  
> something daft. [Again, fortunately that one got corrected -  
> eventually - in the next GHC release.] I try to run sdist, and  
> discover that that's broken on Windows too. But don't worry, there's  
> a replacement tool... which is also broken on Windows... This is an  
> exercise in pure frustration! Sometimes it seems as if *everything*  
> is broken on Windows.
> Hmm... I'm just ranting now. One presumes that when they "fixed"  
> cabal sdist to work on Windows, at least one person checked that it  
> did, in fact, work. That would mean it got broken again at some  
> point after this. Maybe I just need to find an older version or  
> something...
> And after that... I guess I create *another* account on *another*  
> bug tracker and submit *another* "hey, this is broken on Windows"  
> ticket...
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list