[Haskell-cafe] hackage, gtk2hs

Peter Gavin pgavin at gmail.com
Thu Jan 1 13:32:08 EST 2009

Cetin Sert wrote:
> Hi,
> A package I want to upload only builds with the unreleased gtk2hs 
> version from the darcs repository and not the latest released version 
> 0.9.13 or any lesser. But the repository version seems to not have 
> changed, so if I say in my cabal file:
> gtk >= 0.9.14
> it does not even build with the gtk2hs version from the repos, on the 
> other hand
> if I say:
> gtk >= 0.9.13
> people using 0.9.13 may be surprised to see the package does not build.
> What should I do o__O? Wait for the next gtk2hs release before releasing 
> my package? Or is there a way to notify _potential users/those 
> interested_ of the need to use the latest gtk2hs they can get from the 
> darcs repos.

It's not good practice to make releases that depend on unreleased packages.  On 
the other hand, I plan on doing a release real soon now (hopefully by Monday or 
so).  So I would suggest that you wait just a few more days.

I think we're going to make this one 0.10.0, btw.


> Best Regards,
> Cetin Sert
> ------------------------------------------------------------------------
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list