[Haskell-cafe] Upgraded to GHC 6.12 and can't find anything

Tom Hawkins tomahawkins at gmail.com
Mon Dec 28 18:43:07 EST 2009


I haven't tried GHC 6.12 or the Haskell Platform yet, but here is our
standard install procedure for our company, which has worked
consistently for us since GHC 6.8 (we use ubuntu 9.04 32-bit):

- Add ~/.ghc/bin and ~/.cabal/bin to PATH.

- Download and extract latest ghc.  Then from directory:
  $ configure --prefix=$HOME/.ghc && make install

- Download and extract cabal-install from hackage.  Then from directory:
  $ ./bootstrap.sh

- Update cabal package database:
  $ cabal update

- Install required libs and tools:
  $ cabal install darcs atom ...

When we upgrade GHC, we typically nuke ~/.cabal and ~/.ghc and start
over.  The whole process usually only takes about 20 minutes.


On Tue, Dec 29, 2009 at 12:02 AM, Jon Harrop <jon at ffconsultancy.com> wrote:
> On Monday 28 December 2009 21:06:20 Gregory Propf wrote:
>> Ok, I'm trying to build the haskell platform but getting this.  Anyone know
>> what the problem is?  As far as I know I have all the development libs for
>> OpenGL.  I'm not sure what this means.  I'm running Ubuntu 9.04 on a 64bit
>> dual core AMD.
> I had the same problem with Debian Lenny on a 32-bit 2x quadcore Opteron:
>  http://groups.google.com/group/fa.haskell/msg/34ee76bed380438d
> I found that installing the binary Debian packages (from Sid) haskell-platform
> and ghc6, and then installing ghc 6.12 from source fixed 6.10. Now I seem to
> be able to compile with 6.10 and programs run without segfaulting (but not
> 6.8 or 6.12). I never managed to get cabal to work though...
> --
> Dr Jon Harrop, Flying Frog Consultancy Ltd.
> http://www.ffconsultancy.com/?e
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list