[Haskell-cafe] Upgraded to GHC 6.12 and can't find anything

Gregory Propf gregorypropf at yahoo.com
Mon Dec 28 16:06:20 EST 2009

Ok, I'm trying to build the haskell platform but getting this.  Anyone know what the problem is?  As far as I know I have all the development libs for OpenGL.  I'm not sure what this means.  I'm running Ubuntu 9.04 on a 64bit dual core AMD.

Preprocessing library GLUT-
Building GLUT-
Registering GLUT-
Setup: GLUT- dependency
"OpenGL-" doesn't exist (use --force
to override)

Building the GLUT- package failed
make: *** [build.stamp] Error 2
make: Target `default' not remade because of errors.

--- On Sun, 12/27/09, Ivan Lazar Miljenovic <ivan.miljenovic at gmail.com> wrote:

From: Ivan Lazar Miljenovic <ivan.miljenovic at gmail.com>
Subject: Re: [Haskell-cafe] Upgraded to GHC 6.12 and can't find anything
To: "Gregory Propf" <gregorypropf at yahoo.com>
Cc: "Haskell-Cafe" <haskell-cafe at haskell.org>
Date: Sunday, December 27, 2009, 11:30 PM

Gregory Propf <gregorypropf at yahoo.com> writes:

> I finally compiled and installed GHC 6.12 on my Linux system and it seems to be failing to find a lot of things.  Notably these
> import Control.Monad
> import Control.Monad.State
> import Control.Monad.Trans
> import Control.Parallel

A lot of these kinds of modules were not actually part of GHC but
installed as part of GHC's "extralibs" packages (which is being replaced
by the Haskell platform).

You can get the first three modules by installing mtl and the last by
installing parallel, both of which can be found on Hackage.

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20091228/7372af1e/attachment.html

More information about the Haskell-Cafe mailing list