[Haskell-cafe] problem with editline install

Judah Jacobson judah.jacobson at gmail.com
Fri Dec 25 12:53:13 EST 2009

On Fri, Dec 25, 2009 at 2:17 AM, Andrew U. Frank
<frank at geoinfo.tuwien.ac.at> wrote:
> i tried to install editline (because i wanted to install djinn, which depends
> on it):
> with cabal install and with downloading and runghc Setup.lhs configure
> i got the same error:
> checking for completion_matches... no
> configure: error: editline not found, so this package cannot be built
> See `config.log' for more details.
> in the log i did not see anything helpful (at my level of understanding).
> i could then install with synaptic because a deb package existed for ubuntu).
> what did i wrong? thanks for helpful comments

You probably need to install the Ubuntu libedit-dev package, which
contains the necessary C headers.  Note that's different than the
libeditline-dev package, which is an old version of the library
missing some important features.


More information about the Haskell-Cafe mailing list