[Haskell-cafe] Re: haxr build failure from cabal

Christian Maeder Christian.Maeder at dfki.de
Wed Apr 22 11:30:54 EDT 2009

I think you can pass "--preference=HTTP==3001.1.5" to cabal-install
0.6.2, try

  cabal install haxr --preference=HTTP==3001.1.5

Cheers Christian

Jeff Heard wrote:
> haxr will no longer compile from cabal because of the dependency
> marked HTTP > 1.0.  The current version of the library requires HTTP <
> 4000.0.0 as it stands.  Can it be updated real quick in hackage?
> -- Jeff

More information about the Haskell-Cafe mailing list