[Haskell-cafe] Hackage checks

Andrea Rossato mailing_list at istitutocolli.org
Sat Sep 13 15:27:22 EDT 2008

On Sat, Sep 13, 2008 at 08:12:07PM +0100, Duncan Coutts wrote:
> Any path in your .cabal file that uses dist/ is wrong.
> I can't think of any other workaround for 1.2 so I think you'll have to
> require Cabal-1.4 for your package.

Well, since ghc-6.8.3 comes with Cabal-1.2.4, having a package that
works for the great majority of ghc users may be "less wrong" then
having a correct cabal package that requires you to upgrade Cabal, in
order to get rid of strange and incomprehensible error such as
"Unknown symbol" linker complains.

Or at least this is what I thought. I believe I can cope with users
complaining for unexpected results when --builddir is used. They
should be hopefully less, even though I'm not so sure.

Correctness seems a minor problem, here.


More information about the Haskell-Cafe mailing list