[Haskell-cafe] Linux version of ghc-6.8.3 won't intall or run for me: "Floating point exception".

Alan Mackenzie acm at muc.de
Thu Sep 4 18:22:46 EDT 2008

Hi, Don!

On Thu, Sep 04, 2008 at 02:24:20PM -0700, Don Stewart wrote:
> acm:
> > Hi, Haskell!

> > I've downloaded the ghc-6.8.3-i386-unknown-linux.tar.bz2 tarball,
> > which I expected to work on my GNU/Linux box (1.2 GHz Athlon, Debian
> > Sarge).

> Was there a problem installing GHC from the Debian package system with
> apt?

Yes, my apt setup is broken.  Because of a (now fixed) configuration
error I made, aptitude (a frontend to apt) has decided it needs to
delete ~400 packages from my system, some of them vital.  It's an
"intelligent", "helpful" system, and maintaining consistency between
packages is of utmost importance to it, more important, by far, than
leaving my system in a working state.  I haven't found a convenient,
safe, way of resetting this "deletion cache" (which has been hanging
around for ~1 year).  Sadly its only "go button" is "do everything
pending", so I've effectively blocked myself from using it.  Sorting the
mess out, or even discovering whether I could safely use apt directly,
is just too much drudgery; I'll be installing a new system sometime soon

I hate package managers almost as much as binary packages.  There are
quite a lot of things I don't hate, though.  ;-)

That's kind of drifting off topic, though.

> -- Don

Alan Mackenzie (Nuremberg, Germany).

More information about the Haskell-Cafe mailing list