[Haskell-cafe] Linux binary dist problems

Colin Fleming colin.mailinglist at gmail.com
Tue Oct 7 17:38:43 EDT 2008

Ok, I tried nix but I couldn't get it to work. Initially I had a problem
since I was trying to get nix to install in my home directory and on the
host (Dreamhost) that's actually a symlink, which nix doesn't allow. Then
once I got it installed finally it didn't build - I can't remember the
details exactly. I then tried to generate hc files for 6.6.1 to install that
to bootstrap from, but I couldn't get ghc to build those on my machine -
looking around it seems to have a lot of problems building on Leopard. My
last resort is now to install Ubuntu in VMWare, install ghc, then generate
the hc files on that, get those on my host, bootstrap from that, and then
build 6.8.3 from source.

As an aside, is there any reason the tar of the hc files isn't available for
download for versions that support it? It would make this a lot easier.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20081007/dbb043b2/attachment.htm

More information about the Haskell-Cafe mailing list