[Haskell-cafe] GHC 6.10.1 and cabal[-install]

Daniel McAllansmith dm.maillists at gmail.com
Wed Nov 19 16:41:59 EST 2008

On Wed, 19 Nov 2008 21:27:36 Duncan Coutts wrote:
> It's even easier than that! Someone has done it already :-)
> http://hackage.haskell.org/trac/hackage/ticket/261
> Thu Aug 28 16:55:16 CEST 2008  Chry Cheng <chrycheng at gmail.com>
>   * Marking packages deprecated
>   Fixes ticket no. 261 as discussed in its annotations.  Packages with
> "deprecated" "true" are excluded from the package list.  Packages with
> "superseded by" tags provide links to their superseding packages in the
> package page.

Does "excluded from the package list" mean that deprecated packages won't show 
up on http://hackage.haskell.org/packages/archive/pkg-list.html ?

If so, how does one go about finding and downloading deprecated packages?  
Rely on the search function to find the package page?
How do you get a comprehensive list of the deprecated packages that have 

Perhaps there should be a deprecated-pkg-list.html page.
If being superseded implies deprecation this page is also where the superseded 
packages would go, with appropriate supersedes/superseded-by links between 

More information about the Haskell-Cafe mailing list