[Haskell-cafe] test driving cabal install... cabal install and normal install (runghc Setup) don't mix... two package.conf files...

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Fri May 30 06:03:57 EDT 2008

On Thu, 2008-05-29 at 20:12 -0700, Philip Neustrom wrote:

> I'm having issues trying to get cabal-install (latest darcs)
> installed, as well.  I'm seeing the message:
> Hackage/Types.hs:19:29:
>     Module `Distribution.Version' does not export `Dependency'
> which was mentioned on this list earlier.  Updating to the latest
> darcs Cabal doesn't do the trick, it seems:
> $ ghc-pkg list
> /usr/local/lib/ghc-6.8.2/package.conf:
>     Cabal-1.3.10, Cabal-1.5.2, ...
> I grabbed that 1.3.10 as a tarball snapshot.

If you used the tarball of Cabal then you'd want the corresponding
tarball of cabal-install that was released at the same time. Otherwise
the darcs version of one requires the darcs version of the other.

>   The darcs cabal installs Cabal-1.5.2, and it seemed that the darcs
> cabal-install wanted >= 1.3.11 && < 1.5, so I've no idea what to do
> here :)

I'll be making the 1.4 release from this branch:

which is currently at version 1.3.11 since we've not hit 1.4 yet.


More information about the Haskell-Cafe mailing list