[Haskell-cafe] test driving cabal install... cabal install and normal install (runghc Setup) don't mix... two package.conf files...

Philip Neustrom philipn at gmail.com
Thu May 29 23:12:10 EDT 2008

Excerpts from Thomas Hartman's message of Thu May 29 18:11:04 -0700 2008:
> After a little drama with zlib, I managed to get cabal-install installed.
> I then attempted to do
> cabal install HAppS-Server
> since this is a module with a lot of dependencies, and in rapid
> development flux, so perenially painful for me to install.
> The result is that I managed to install everything up to HAppS-State,
> which I think is the last dependency, but then seemed to hang
> indefinitely in the middle of installing HAppS-Server at the end.
> OK, I thought, then perhaps I can do normal runghc Setup.hs after
> downloading and unzipping the tar from
> http://hackage.haskell.org/cgi-bin/hackage-scripts/package/HAppS-Server-
> However, this resulted in error
> thartman at thartman-laptop:~/haskellInstalls/smallInstalls/HAppS-Server->ru
> nghc
> Setup.hs configure
> ...
> Setup.hs: At least the following dependencies are missing:
> HAppS-Data >=0.9.2...
> Strange, because I had just installed that module via cabal-install,
> and I could load it in ghci with :m +HappS.Data.
> I then ran ghc-pkg and got this strange result that my packages were
> broken into two different files. Is this by design?
> ghc-pkg list
> /usr/local/lib/ghc-6.8.2/package.conf:
>     Cabal-, Cabal-1.3.11, Cabal-1.5.2, DeepArrow-0.2,
> ....
> /home/thartman/.ghc/i386-linux-6.8.2/package.conf:
>     HAppS-Data-, HAppS-IxSet-, HAppS-State-,
> I am curious if anybody else is able to install HAppS-Server using
> cabal install, and whether they can shed any light on the other isuses
> I raised.
> Thomas.

I'm having issues trying to get cabal-install (latest darcs) installed, as well.  I'm seeing the message:

    Module `Distribution.Version' does not export `Dependency'

which was mentioned on this list earlier.  Updating to the latest darcs Cabal doesn't do the trick, it seems:

$ ghc-pkg list
    Cabal-1.3.10, Cabal-1.5.2, ...

I grabbed that 1.3.10 as a tarball snapshot.  The darcs cabal installs Cabal-1.5.2, and it seemed that the darcs
cabal-install wanted >= 1.3.11 && < 1.5, so I've no idea what to do here :)

--Philip Neustrom

More information about the Haskell-Cafe mailing list