[Haskell-cafe] strange cabal error

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Sat May 24 05:36:15 EDT 2008

On Fri, 2008-05-23 at 15:07 -0500, John Lato wrote:
> Hello,
> I recently ran into a strange cabal error.  When trying to configure a
> package (leksah 0.1.1) I get the following error:
> MacBook-Pro:leksah-0.1.1 jwl$ runhaskell Setup.lhs configure
> Configuring leksah-0.1.1...
> Setup.lhs: ghc version >=6.2 is required but the version of
> /usr/local/bin/ghc could not be determined.
> MacBook-Pro:leksah-0.1.1 jwl$ /usr/local/bin/ghc --version
> The Glorious Glasgow Haskell Compilation System, version 6.8.2

Run the configure step again with -v3, we should be able to see in the
log exactly what string we got back from ghc.

Also, to make sure you're using the version of the Cabal library you
expect, try:

ghc --make Setup.hs -package Cabal-
./Setup configure

That way we know what we're using, even if you happen to have multiple
versions of Cabal installed or if runhaskell happens to point at hugs
rather than ghc.


More information about the Haskell-Cafe mailing list