[Haskell-cafe] strange cabal error

John Lato jwlato at gmail.com
Fri May 23 16:07:21 EDT 2008


I recently ran into a strange cabal error.  When trying to configure a
package (leksah 0.1.1) I get the following error:

MacBook-Pro:leksah-0.1.1 jwl$ runhaskell Setup.lhs configure
Configuring leksah-0.1.1...
Setup.lhs: ghc version >=6.2 is required but the version of
/usr/local/bin/ghc could not be determined.

MacBook-Pro:leksah-0.1.1 jwl$ /usr/local/bin/ghc --version
The Glorious Glasgow Haskell Compilation System, version 6.8.2

This is on Mac OS 10.5.2, with GHC 6.8.2 (installed from Manuel C.'s
binary package).  Thus far several other packages have built and
installed just fine (bytestring, binary, parsec, gtk2hs (from source,
not darwinports)).  Looking through leksah.cabal and Setup.lhs, I
didn't see anything unusual (although I'm far from a cabal expert).

I only found one relevant result from google, a Nov. 20th message on
cabal-devel about another user getting this message on Debian with ghc
6.8.1.  He reported getting this message when running install from a
directory without write permissions.  It doesn't seem to be a
permissions problem for me; I do have write permissions for the
directory in which I'm running cabal and all subdirectories.

Can anyone tell me what's going on, or give me any advice to try?
Would a different version of cabal possibly work?

John Lato

More information about the Haskell-Cafe mailing list