[Haskell-cafe] cabal Setup.hs configure - cabal doesnt produce a setup-config

geoffrey lordgeoffrey at optushome.com.au
Mon May 19 04:14:40 EDT 2008

I did a complete uninstall and reinstall of GHC and that seems to have
fixed it. 
So i probably broke things (i guess).

On Sun, 2008-05-18 at 17:11 -0400, Gwern Branwen wrote:

> On 2008.05.19 06:53:22 +1000, geoffrey <lordgeoffrey at optushome.com.au> scribbled 1.8K characters:
> >    Hi,
> >    I am trying to install nanocurses, but cabal isn't creating the setup-config file in dist/
> >
> >    I have run (and re-run) runghc Setup.hs configure
> >    The first time it complained about mpg123 (whatever that is) so i installed the other
> >    dependencies - unix & bytestring
> The mpg123 warning is leftover from hmp3; mpg123 is a media player hmp3 needs to actually play the audio files. I hadn't noticed it. Obviously it has no relevance to a curses binding, so I've edited that out and uploaded a small version bump.
> >    Then i tried to re-run setup configure for nano again. Configure creates the dist directory
> >    but no files.
> >    I have deleted and untarred the files and retried,but to no avail.
> >
> >    Any clues?
> >    Thanks.
> >
> >    (OS: Ubuntu hardy, GHC: 6.8.2)
> Dunno. If Cabal usually works for you, but just no with nanocurses, my guess would be perhaps the mpg123 check is causing the configure script to bail out?
> --
> gwern
> AVIP DCSS SAS PGP Scud counter rs9512c Meta-hackers Fax IW
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20080519/e763c42a/attachment.htm

More information about the Haskell-Cafe mailing list