[Haskell-cafe] HSFFIG compilation problem

Harri Kiiskinen harkiisk at utu.fi
Tue May 13 17:31:17 EDT 2008


I've tried to compile hsffig-1.0pl2, unsuccesfully, also from the
unstable darcs repo. I'm using ghc-6.8 (ghc6-6.8.2 from Debian
unstable). HSFFIG comes with its own version of Cabal, but I cannot get
past the configuration phase (./cabal-setup configure), when I get the
following output:

Configuring HSFFIG-1.0...
configure: searching for ghc in path.
configure: found ghc at /usr/bin/ghc
configure: looking for package tool: ghc-pkg near compiler
in /usr/bin/ghc
configure: found package tool in /usr/bin/ghc-pkg
configure: Using install prefix: /usr/local
configure: Using compiler: /usr/bin/ghc
configure: Compiler flavor: GHC
configure: Compiler version: 6.8.2
configure: Using package tool: /usr/bin/ghc-pkg
configure: Using haddock: /usr/bin/haddock
configure: Using happy: /usr/bin/happy
configure: Using alex: /usr/bin/alex
configure: Using hsc2hs: /usr/bin/hsc2hs
configure: Using cpphs: /usr/bin/cpphs
configure: Reading installed packages...
configure: Dependency base-any: using base-
cannot satisfy dependency text-any

Does anyone have an idea, how the dependency 'text-any' could be

Harri K.

More information about the Haskell-Cafe mailing list