[Haskell-cafe] build recent(ish) ghc on macos 10.3.9 powerpc?

Uwe Hollerbach uhollerbach at gmail.com
Tue Mar 18 22:11:45 EDT 2008

Hello, haskellers, a few days ago I had asked about building recent
ghc on macos 10.3.9. I have made a bit of progress along those lines,
here's a small update on what worked and what didn't. Instead of
trying to proceed with the porting procedure, I went back to an
install: I ended up going to 6.2.2. After a bit of fiddling, I found
that another bit of messing-about I had done to the machine was
messing me up: I had upgraded gcc from 3.3.x to 3.4.6 by just
downloading the sources and building. That produced a working gcc
3.4.6, but apparently the apple-aware ghc 6.2.2 and the apple-unaware
gcc 3.4.6 didn't play nicely together. Once I disabled gcc 3.4.6,
stuff worked again.

Then I tried building ghc 6.4.2 using the installed 6.2.2. This took a
lot of time, the compiler was able (as far as I could tell) to go
through all of its own bootstrapping, but after I happily installed
what I thought was a working ghc 6.4.2, the installed version was
unable to do anything: it segfaulted while trying to do "ghc
--version". Oops... Out of somewhat morbid curiosity, I tried running
that inside the debugger, but gave up after several hours of elapsed
time. Back to the drawing board.

So I tried jumping directly from 6.2.2 to 6.6.1; that is, using 6.2.2
to build 6.6.1. That took another lot of time, but I'm happy to report
that it has produced a working executable: it did proceed all the way
through its bootstrapping, I verified that the executable in
compiler/stage2 was able to run "ghc --version" in-place, and after I
installed it, it was still able to do that; and (extra bonus! :-) )
it's also able to compile and link at least one small Haskell program
written by me! Cool!

I'm going to keep going forward and try to build 6.8.2, and I'll
report back if that succeeds, but this is already pretty good

regards, Uwe

More information about the Haskell-Cafe mailing list