[Haskell-cafe] Error in configure script for GHC

Reid Barton rwbarton at math.harvard.edu
Fri Jun 27 14:59:20 EDT 2008

On Fri, Jun 27, 2008 at 10:15:23AM -0400, Jefferson Heard wrote:
> I've tried all the 6.6 and 6.8 versions, trying to compile them on a
> RHEL-based supercomputer, and I always see this error when I run
> ./configure:
> -bash-3.00$ ./configure
> checking build system type... x86_64-unknown-linux-gnu
> checking host system type... x86_64-unknown-linux-gnu
> checking target system type... x86_64-unknown-linux-gnu
> Which we'll further canonicalise into: x86_64-unknown-linux
> checking for path to top of build tree... pwd: timer_create: Invalid
> argument
> configure: error: cannot determine current directory

I don't know whether this is related, but I've noticed that the most
recent source distribution of the HEAD branch (ghc-6.9.20080615)
includes a binary executable utils/pwd/pwd compiled for x86-64.  This
causes ./configure to break with a similar message, since I have a
32-bit system.  If I delete utils/pwd/pwd, the configure script
automatically rebuilds it and then completes successfully.

Reid Barton

More information about the Haskell-Cafe mailing list