[Haskell-cafe] Problem building GHC 6.8.3

Bryan O'Sullivan bos at serpentine.com
Wed Jun 18 11:19:57 EDT 2008

On Wed, Jun 18, 2008 at 5:28 AM, Daniel Fischer
<daniel.is.fischer at web.de> wrote:
> Sorry, probably stupid questions for knowledgeable folks

Not stupid at all, but possibly the wrong mailing list.
glasgow-haskell-users would usually be a better place to ask.

> Setup: Haddock's internal GHC version must match the configured GHC version

You're using Haddock 2.0 or newer. It's not actually possible to build
GHC with it; you must use Haddock 0.9.

Many other packages apparently break with Haddock 2, but GHC is
certainly rather visible :-)  It is possible to have Haddock 0.9 and
2.0 installed simultaneously under different names or in different
locations, but you'll have to patch GHC's sources in order to specify
which Haddock to use. It's a small patch; look on Trac for it.

More information about the Haskell-Cafe mailing list