[Haskell-cafe] Problem building GHC 6.8.3

Daniel Fischer daniel.is.fischer at web.de
Wed Jun 18 08:28:25 EDT 2008

Sorry, probably stupid questions for knowledgeable folks, but after having 
built for a couple of hours, make died with

if ifBuildable/ifBuildable base; then \
  cd base && setup/Setup haddock --html-location='../$pkg' \
                               --hyperlink-source; \
Preprocessing library base-
Running hscolour for base-
Preprocessing library base-
Running Haddock for base-
Warning: The documentation for package rts-1.0 is not installed. No links to 
it will be generated.
Setup: Haddock's internal GHC version must match the configured GHC version
make[1]: *** [doc.library.base] Fehler 1
make[1]: Leaving directory `/home/dafis/HasCom/ghc-6.8.3/libraries'
make: *** [stage1] Fehler 2

So, what is Haddock's internal GHC version?
Is it the version, haddock was built with?

And what is the configured GHC version, is it the one I'm trying to build or 
the one I'm building with? 
If the former, I seem to have landed in a circulus vitiosus, if the latter, 
that is the GHC, haddock was built with, too.

For the record:
dafis at linux:~/HasCom/ghc-6.8.3> haddock --version
Haddock version 2.1.0, (c) Simon Marlow 2006
Ported to use the GHC API by David Waern 2006-2008

How should I proceed now?


More information about the Haskell-Cafe mailing list