[Haskell-cafe] Difficulty installing hscurses

Dominic Espinosa dcespin at fastmail.fm
Fri Jun 13 05:15:25 EDT 2008


I'm trying to install hscurses on debian-testing. I have ghc6 installed,
which I've written some toy programs with, but I haven't tried to
install any Hackage packages until now.

hscurses depends on old-time and old-locale (those names make me raise
my eyebrows a bit). In turn, old-time seems to depend on old-locale. So,
I tried installing old-locale first. In installed fine. Now I'm trying
to install old-time:

$ runhaskell Setup.hs configure
Warning: defaultUserHooks in Setup script is deprecated.
Configuring old-time-
Warning: The 'build-type' is 'Configure' but there is no 'configure' script.

(given these warnings, I don't really expect the next command to
succeed, but what the hell:)

$ runhaskell Setup.hs build

Preprocessing library old-time-
Building old-time-

    Could not find module `System.Locale':
      it was found in multiple packages: old-locale- base

No idea what to do here. Is old-time conflicting with whatever "time"
package superseded it, or what?

I'm new to Haskell, and understanding the guts of its packaging system
is a bit beyond me right now. Sorry if this is a FAQ or something, but I
tried some Google searches and found nothing useful.

Any help or tips appreciated.

More information about the Haskell-Cafe mailing list