[Haskell-cafe] Re: poll: how can we help you contribute to darcs?

Trent W. Buck trentbuck at gmail.com
Sun Aug 3 20:21:54 EDT 2008

Ashley Moran <ashley.moran at patchspace.co.uk> writes:
> On Aug 03, 2008, at 5:36 pm, Ketil Malde wrote:
>> Seems I needed a newer darcs - the one shipped with Ubuntu is 1.0.9,
>> which appears to be too old, and it works when I build a new 2.0.2
>> from the tarball.  (Anybody with write access to the front page who
>> can make a note of minimum version required to 'darcs get' the
>> repository?)

AFAIK, the current darcs darcs repo should be gettable with any 2.x
version of darcs.

Since darcs is self-hosting, you gotta expect bootstrapping issues when
using older-than-the-current-release versions to checkout the repo.
(Hence grabbing the source tarball.)

> FYI, Iain Lane made a darcs package for 2.0.2:
> https://launchpad.net/~laney/+archive

You should also be able to backport it from Intrepid (Hardy+1).  There
may be a hardy-backports version, too, but packages.ubuntu.com won't
talk to me just now.

More information about the Haskell-Cafe mailing list