[Haskell-cafe] Hackage being too strict?

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Mon Apr 21 15:43:55 EDT 2008

On Mon, 2008-04-21 at 14:30 -0400, Brandon S. Allbery KF8NH wrote:
> On Apr 21, 2008, at 7:38 , Hans van Thiel wrote:
> > On Fri, 2008-04-18 at 16:19 +0100, Duncan Coutts wrote:
> >> If there are any that you think are rejecting legitimate packages  
> >> then do
> >> complain (as in this thread).
> > Configuring Emping-0.5.1...
> > cabal-setup: At least the following dependencies are missing:
> > gtk -any
> cabal-install doesn't handle the case of ghc packages that aren't  
> named the same as hackage packages?  (gtk is part of the gtk2hs hackage)

Or rather, Cabal defines the package name to be the same as the ghc
package. So gtk2hs is not a hackage package at all and it's not on
hackage. When we do get it cabalised it'll be 9 (semi-)independent cabal


More information about the Haskell-Cafe mailing list