[Haskell-cafe] Re: Is "take" behaving correctly?
jules at jellybean.co.uk
Thu Sep 13 04:56:11 EDT 2007
Neil Mitchell wrote:
>> Although I appluad the semantics of the safe package, I'm not delighted
>> with the idea of replacing our concise elegant standard library names
>> with uglyAndRatherLongCamelCaseNamesThatCouldBePerlOrEvenJava though.
>> Conciseness of expression is a virtue.
> They aren't that long - merely an extra 4 characters over the standard
> one to indicate what the specific semantics are. If you can think of
> better names, then I'm happy to make use of them.
No, they're not, and it wasn't intended as a slight against your naming
choice. I don't have a better suggestion.
The problem I was really trying to point at, but didn't express at all
well, was that a proliferation of similar functions with slightly
different names (like Conor's four versions of zipWith) doesn't make a
very elegant library API. It's nicer to settle on a smaller number of
primitives. I don't actually have a solution that I think is "good" for
the head/tail/take/drop issue :-(
More information about the Haskell-Cafe