[Haskell-cafe] Re: [Haskell] Re: Trying to install binary-0.4

Claus Reinke claus.reinke at talk21.com
Tue Oct 16 06:29:11 EDT 2007

> Be happy: we're about 15 years ahead of the lisp guys. 'cabal install
> xmonad' works, for example.

- not on windows (and since it is popular, it will seduce more
    good haskellers not to bother with windows compatibility.. :-(

- from xmonad.cabal (version 0.3, from hackage):

    build-depends:      base>=2.0, X11>=1.2.1, X11-extras>=0.3, mtl>=1.0, unix>=1.0

so, you guarantee that it will work with base-3.0, X11-2.0, 
X11-extras-1.0, mtl-2.0, unix-2.0. even though all of those
will -if i now understand the versioning intentions correctly-
lack features of the current versions?


More information about the Haskell-Cafe mailing list