[Haskell-cafe] Re: [Haskell] Re: Trying to install binary-0.4

ChrisK haskell at list.mightyreason.com
Tue Oct 16 04:06:40 EDT 2007

Don Stewart wrote:
> stefanor:
>> On Mon, Oct 15, 2007 at 10:57:48PM +0100, Claus Reinke wrote:
>>> so i wonder why everyone else claims to be happy with the status quo?
>> We aren't happy with the status quo.  Rather, we know that no matter how
>> much we do, the situation will never improve, so most of us have stopped
>> wasting out time.  Furthermore, we know that people who DO offer
>> alternatives instantly lose all public credibility - look at what
>> happened to Alex Jacobson.
>> Stefan (who will readily admit his bleak outlook)
> Be happy: we're about 15 years ahead of the lisp guys. 'cabal install
> xmonad' works, for example.
> -- Don

And that, I think, will be the key to the solution.

Keeping the repository of interdependent libraries consistent is hard, but it is
only a means to an goal.

That goal is applications, not libraries.  My definition of the right version of
libFoo to use is whatever is needed to make an application, such as xmonad, work.


More information about the Haskell-Cafe mailing list