[Haskell-cafe] Installation of GLFW package

Peter Verswyvelen bf3 at telenet.be
Tue Oct 2 04:49:31 EDT 2007

Hi Immanuel,

Are you using Windows or Linux or OSX?

Under Windows, I was able to install it (no need to compile, since the 
libraries are bundled).

I could also run some examples from the SOE book, however IMO the GLFW 
Haskell wrapper seems to contain some bugs (at least on Windows) that 
prevented some demos from working. I locally fixed the GLFW.hs file so 
that all seems to work.

But you don't seem to get to that step yet... I had the error you 
described once when installing another package that had an incomplete 
cabal file, but that can't be the case here I guess...
If you just want to try SOE, you can also try GTK2HS 
http://haskell.org/gtk2hs <http://haskell.org/gtk2hs/> (note you'll have 
to replace each "import SOE" line with "import Graphics.SOE.Gtk)


Immanuel Normann wrote:
> Hello,
> I have just read the thread about "installation of GLUT package" started
> at 9/3/2007 by Ronald Guida. Installation of the GLFW package is very
> much related to that. However, I haven't found the solution for
> installing the GLFW successsfully.
> I have downloaded 
> http://www.cs.yale.edu/homes/hl293/download/GLFW-20070804.zip
> and followed the compile and installation instructions from the
> README.txt file. Actually I haven't noticed any error messages.
> Then I tried SimpleGraphics from SOE (downloaded from
> http://www.cs.yale.edu/homes/hl293/download/SOE-20070830.zip)
> with ghci-6.6. Again loading the file did not raise any error.
> But when I tried to start 
> main
>   = runGraphics (
>     do w <- openWindow 
>               "My First Graphics Program" (300,300)
>        drawInWindow w (text (100,200) "Hello Graphics World")
>        k <- getKey w
>        closeWindow w
>     )
> I got this error message:
> "During interactive linking, GHCi couldn't find the following symbol:
>   GLFWzm0zi1_GraphicsziUIziGLFW_initializze_closure
> This may be due to you not asking GHCi to load extra object files,
> archives or DLLs needed by your current session.  Restart GHCi,
> specifying
> the missing library using the -L/path/to/object/dir and -lmissinglibname
> flags, or simply by naming the relevant files on the GHCi command line.
> Alternatively, this link failure might indicate a bug in GHCi."
> Here I am lost. What is the missing library?
> Regards,
> Immanuel
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20071002/7f1d6ca9/attachment.htm

More information about the Haskell-Cafe mailing list