[Haskell-cafe] Fun with Cabal on Windows! [Stream fusion for Hackage]

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Wed Nov 21 04:50:27 EST 2007

On Tue, 2007-11-20 at 10:35 -0500, Olivier Boudry wrote:
> On 11/19/07, Andrew Coppin <andrewcoppin at btinternet.com> wrote:
>         Well, I just tried to install this, and as per usual, Cabal
>         has having
>         none of it.
>         C:\fusion\> runhaskell Setup configure
>         Configuring stream-fusion-0.1.1...
>         Setup: ld is required but it could not be found. 
> Hi Andrew,
> I had the same problem with ghc-6.8.1 and solved it by adding C:\ghc
> \ghc-6.8.1\gcc-lib to my PATH variable in environment variables. A
> copy of ld.exe is in this directory.
> In ghc-6.6.1, ld.exe was in the same place and it was working out of
> the box for me. I don't understand why it is not found any more with
> ghc-6.8.1.

It turned out that it was a bug that was introduced in Cabal shortly
before the release that went with ghc-6.8.1. We added an extra test to
check if ld supports the -x flag. This change inadvertently broke the
code that finds ld on windows. I can tell you more of the gory details
if you care :-). It's fixed now and will be in the release that goes
with ghc 6.8.2.


More information about the Haskell-Cafe mailing list