[Haskell-cafe] Plugin Problem - Weirder

Daniel Fischer daniel.is.fischer at web.de
Thu Jun 21 12:41:07 EDT 2007

Am Donnerstag, 21. Juni 2007 10:22 schrieb Bayley, Alistair:
> > [mailto:haskell-cafe-bounces at haskell.org] On Behalf Of Daniel Fischer
> >
> > I suppose in contrast to the version from HackageDB, which I
> > got myself on
> > monday, the darcs version works with ghc >= 6.6, or I
> > probably would have
> > heard about it. So I'll try to get me that, only where?
> http://www.cse.unsw.edu.au/~dons/hs-plugins/

I'd already tried that, but
$ darcs get --partial http://www.cse.unsw.edu.au/~dons/hs-plugins/
Invalid repository:  http://www.cse.unsw.edu.au/~dons/hs-plugins

darcs failed:  failed to fetch: 
http://www.cse.unsw.edu.au/~dons/hs-plugins/_darcs/inventory ExitFailure 1

Is my darcs too old (version 1.0.5) or is the repo actually broken?
> AFAIUI, version 1.0 will work with ghc6.6 on non-Windows platforms. It's
> been broken on Windows for some time, and I don't really know why. As
> you seem to be on Linux, this shouldn't affect you.
> Alistair

Well, again, the .tar.gz from HackageDB is tagged 1.0, it definitely doesn't 
work with ghc-6.6.1 on my linux. And it apparently was packed in February, so 
it shouldn't be too out of date.

Let me summarize my findings so you guys have something to reason from.
1) if I compile the module and execute the binary, I get
$ PlugTest
PlugTest: /tmp/MKtHcN2822.o: unknown symbol 
PlugTest: user error (resolvedObjs failed.)

2) If I load the compiled code into ghci, load cannot ever find the symbol 
resource, originally that is because it looks for main_resource_closure 
instead of ModuleName_resource_closure.
Now I changed the code in System.Plugins.Load, so that load does look for the 
correct symbol, with baffling results. In compiled code, all loads still 
fail. If I load interpreted code into ghci, the first load succeeds, hooray! 
But all subsequent loads fail, until I :reload (sometimes) or :load PlugTest 
(that always worked so far). How come? When I added debugging output, I could 
see that it looked for the correct symbols in the correct .o files, but only 
the first found the symbol. Very peculiar.

Could somebody please enlighten me?


More information about the Haskell-Cafe mailing list