[Haskell-cafe] Re: Plugin Problem

Daniel Fischer daniel.is.fischer at web.de
Wed Jun 20 19:49:15 EDT 2007

It half worked in ghci. Only all evals failed. That gave me a lead and after a 
lot of tinkering with the code of plugins-1.0, I found out one major problem.
As of 6.6, ghc calls all interfaces 
interface main:Modulename
and so plugins tries to load main_resource_closure instead of 
Modulename_resource_closure. That of course fails.
Unfortunately, I don't know how to fix it.
I suppose in contrast to the version from HackageDB, which I got myself on 
monday, the darcs version works with ghc >= 6.6, or I probably would have 
heard about it. So I'll try to get me that, only where?

And I'm rather annoyed that the stuff from HackageDB tends to be obsolete.
How could we attract people to Haskell, if the downloaded packages just don't 

Am Mittwoch, 20. Juni 2007 20:32 schrieb ich:
> Hi again,
> I thought, I'd try out the plugins package, cause lambdabot segfaulted
> while loading plugins (or immediately after).
> So I wrote a very simpleminded test for eval(_) and unsafeEval(_) from
> System.Eval.Haskell.
> Compiled, but:
> dafis at linux:~/Documents> ghc --make PlugTest
> [1 of 1] Compiling Main             ( PlugTest.hs, PlugTest.o )
> Linking PlugTest ...
> dafis at linux:~/Documents> PlugTest
> PlugTest: /tmp/MectNX2619.o: unknown symbol
> `pluginszm1zi0_AltDataziDynamic_toDyn_closure'
> PlugTest: user error (resolvedObjs failed.)
> What does that tell more knowledgeable persons?
> Thanks,
> Daniel

More information about the Haskell-Cafe mailing list