[Haskell-cafe] GHC 6.6.1: Where is Graphics.SOE ?

Dmitri O.Kondratiev dokondr at gmail.com
Fri Jul 20 05:47:01 EDT 2007

Olivier Boudry olivier.boudry at gmail.com wrote:
(Wed Jul 18 11:56:56 EDT 2007)

>Hi Dmitri,
>I built gtk2hs on Windows with GHC 6.6.1 and gtk2hs-0.9.11. Here's are the
>steps that worked for me: (not sure I didn't missed some)
>First you need to install a GTK+ development package for windows. I think
>mine comes from http://gladewin32.sourceforge.net/modules/wfdownloads/
>Then you must have MSYS and MinGW installed on your computer. You'll find
>information on how to install this here:
>Once you've installed that stuff you can start a MSYS shell. You'll need to
>set some environment variables for GTK (adapt to your path):
>export GTK_BASEPATH=/c/GTK_2.0
>export GTK_CONFIG_PATH=/c/GTK_2.0/lib/pkgconfig
>Cd to the gtk2hs source directory and type:
>./configure --prefix=/c/Progra~1/Haskell
>make install
>Hope this helps.
>Good luck,

Oliver, thanks!
I tried that, yet have some problems.

I use:
GHC 6.6.1, current development version of Gtk2hs (not sure what version),
Gtk+ 2.10.11 (Win32)
and latest available from MinGW distributions:

Problem 1.
Gtk2hs build requires to run autoreconf. So  in MSYS I have:

$ autoreconf
/usr/share/aclocal/autoopts.m4:22: warning: underquoted definition of
  run info '(automake)Extending aclocal'
  or see
configure.ac:101: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

Notwithstanding this error autoreconf creates configure script. When I run
it I get:

Problem 2.
$ ./configure --with-hc=/c/usr/ghc-6.6.1 --prefix=/c/usr/ghc-6.6.1
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-mingw32
checking host system type... i686-pc-mingw32
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH

1) Should I ignore autoreconf errors?
2) I thought that building Gtk2hs is done with GHC only. Is it right that
build requires C compiler?
3) Any other ideas what is wrong with this build?


Dmitri O. Kondratiev
dokondr at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20070720/ad933a22/attachment.htm

More information about the Haskell-Cafe mailing list