[Haskell-cafe] What's wrong with "cgi-undecidable"?
bringert at cs.chalmers.se
Sat Feb 10 17:37:04 EST 2007
On Feb 10, 2007, at 9:15 , Donald Bruce Stewart wrote:
>> <keepbal at gmail.com> said:
>>> Then another problem,after I unregistered cgi-2006.9.6,the
>>> fastcgi-2006.10.9could't work well with
>>> cgi-1.0 .
>> You might need fastcgi-1.0:
>>> Actually,I was trying my best to install hope:
>>> http://www.cs.chalmers.se/~bringert/darcs/hope and lasted for three
>>> it's really too hard.
> hope really is rather hard to install. You're best 'hope' is to get
> packages from hackage that match version numbers you're after:
> And then anything else from darcs. hope is really the pathological
> for dependencies at the moment. Perhaps shapr or Bjorn can comment
> on the
> issues involed?
> We hope to be able to solve the hope (and other complex package)
> problems with cabal-install, which will pull all dependencies off
> hackage, build them, and build your package, automatically. It's
A few days ago I put some work into the hope.cabal file, so that you
should now be able to use that to build it. Just get the versions of
all packages listed in the current darcs version of hope.cabal. I
think all of them except the haskelldb ones are available from
Hackage. If haskelldb 0.10 was released and uploaded to Hackage, I
think you could even install Hope itself from Hackage.
I've also recently changed the version number scheme on most of the
packages I maintain (which includes most of the packages required by
Hope) from a date-based one to a major.minor scheme. This has the
unfortunate side-effect of making newer versions have smaller version
numbers than older ones, but it felt silly to start with a major
version number of 2008. That might have been a bad decision.
More information about the Haskell-Cafe