[Haskell-cafe] hmake and ghc-6.6

Alexey Rodriguez mrchebas at gmail.com
Wed Nov 1 08:17:01 EST 2006

Hello Haskell people,

I have been trying to build hmake 3.12 using ghc-6.6 on a Fedora Core Linux
running on a dual 64-bit Opteron machine. However, I had the following error
related to the readline library:


/home/t-alexer/packages/hmake-3.12/script/hmake -hc=ghc HInteractive
-d/home/t-alexer/packages/hmake-3.12/targets/x86_64-Linux/obj/interpreter \

         -i../hmake  -package util -package base -DUSE_READLINE=1 -lreadline

Warning: package(s) util not available (according to ghc-pkg)

MkProg: Can't find module Readline in user directories



  Or in installed libraries/packages at



  Asked for by: SimpleLineEditor.hs

  Fix using the -I, -P, or -package flags.

Stop - hmake dependency error.

I googled for this error and I saw the following thread in which Malcolm
suggested having a fix.


I tried to locate hmake's repository but to no avail. There is no link to it
from www.haskell.org/hmake and the hmake in the nhc repository is the same
as the hmake I downloaded.

I will appreciate any help you can offer.


P.S. A related question, has any of you tried to build ghc using hat? I am
trying to do this to study ghc's internals
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20061101/9ec1fdd2/attachment-0001.htm

More information about the Haskell-Cafe mailing list